I installed a gitlab-ce at centos 7.4,but reconfigure failed

but when I use gitlab-ctl reconfigure ,the gitlab-7.2.0-ssh-keygen.pp throws an error,
---- Begin output of semodule -i /opt/gitlab/embedded/selinux/rhel/7/gitlab-7.2.0-ssh-keygen.pp ----
STDERR: libsepol.context_from_record: type gitlab_shell_t is not defined (No such file or directory).
libsepol.context_from_record: could not create context structure (Invalid argument).
libsemanage.validate_handler: invalid context system_u:object_r:gitlab_shell_t:s0 specified for /var/opt/gitlab/gitlab-workhorse/sockets [all files] (Invalid argument).
libsemanage.dbase_llist_iterate: could not iterate over records (Invalid argument).
semodule: Failed!
---- End output of semodule -i /opt/gitlab/embedded/selinux/rhel/7/gitlab-7.2.0-ssh-keygen.pp ----
Ran semodule -i /opt/gitlab/embedded/selinux/rhel/7/gitlab-7.2.0-ssh-keygen.pp returned 1
the gitlab version is gitlab-ce-10.8.7-ce.0.el7.x86_64
System Info:
ruby=ruby 2.3.7p456 (2018-03-28 revision 63024) [x86_64-linux]
I have tried gitlab-ce-14.0.2-ce.0.el7.x86_64、gitlab-ce-13.4.7-ce.0.el7.x86_64,it throws the same error.How can I fix it?Or I need provide more infomation?

Maybe you are missing selinux dependencies, see this post:

Could be missing selinux packages, have you got these installed?

libsemanage-static libsemanage-devel policycoreutils

if it still fails with selinux enabled at this point, it would need debugging using the selinux tools to find out what is blocking.

yeah,I am sure that I install the dependencies and all updated. libsemanage-devel-2.5-14.el7.x86_64,policycoreutils-2.5-34.el7.x86_64,libsemanage-static-2.5-14.el7.x86_64.But the error still throwed

I can not resolve this issue,I prefer that it is a enviroment problem.So i installed gitlab use docker,need not consider env problem