Importing a bitbucket project into gitlab

I have an existing bitbucket repo that I want to migrate to gitlab. Currently I want to explore the gitlab import feature to import my bitbucket repo, so I am selecting
New Project> Import Project

And when I make click to Bitbucket cloud:

I got this Repository not found error message:

That I would expect is that in this step, gitlab wizard or bitbucket ask me for my credentials (I have a bitbucket app password previously created), but it does not, and instead I got the error.
It is like gitlab automatically were identifying that my app password does not have enough permissions. I even created a second one on bitbucket with the proper permissions but I got the same result.

Any clue or orientation will be appreciated.


I would like to confirm that now I am also encountering this issue and am interested in how to solve it.

1 Like

I can also confirm issues with the Bitbucket Cloud import feature, but for me, the process hangs on the “loading screen”.
The problem started to happen somewhere between the 21st and the 23rd of June.

1 Like

Are you using or a self-hosted GitLab instance? There are some things that need to be enabled if you’re using self-hosted. On, I get this login screen for bitbucket cloud when I click the BitBucket Cloud button.

1 Like

Hi @sgrossman I am using service, I see now I am able to import bitbucket repos so in somehow that issue was solved.

Thank you!

can you try different browser? and / or clear out all cookies etc, try incognito, I have a feeling it’s browser related. I might be wrong but worth trying, seen similar behaviour