Install-helm Operation Timed Out

Not sure what to do here. I run my own self-hosted GitLab Core instance, and I’ve been following Add a cluster using cluster certificates (DEPRECATED) | GitLab. Everything went well until I tried to install Helm Tiller from the web interface, regardless of whether I add the cluster within a project or at instance level. The following screenshots show the issue that occurs before and after about 20 minutes of waiting.

The logs are empty as far as I can tell, when running kubectl logs -n gitlab-managed-apps -f -p install-helm. No idea what to try next. I haven’t found a single result with the exact wording my error has so that’s been confusing the heck out of me. I’ll keep browsing the forum for now, but help would definitely be appreciated. I’m not entirely sure how to go about replicating this issue either; if I had my two new server machines that are currently being posted to me, I’d absolutely try setting it up again to see if the issue persists.

~ Bob