Installation on Debian stretch

I try to install gitlab. The setup script adds

deb stretch main
deb-src stretch main

as sources for additional Debian packages.

When I run apt-get update I get

W: Failed to fetch FailReason: ConnectionRefused

obviously gitlab can’t be installed after that.

Hi, and welcome to the forum! :slight_smile:

Quick question: when you run apt update, is the gitlab archive the only one apt fails to connect to?

In other words, what’s the full output of apt update?

I’ve just tried this on my VPS running Ubuntu, and at least the gitlab archive for Ubuntu could be reached out to. That does not mean there might be something specific going on with the one for Debia.

It’s a fresh VM and the gitlab apt repro is the only one that fails.

root@gitlab:~# apt-get update
Err:1 stretch InRelease
FailReason: ConnectionRefused
Hit:2 stretch/updates InRelease
Ign:3 stretch InRelease
Hit:4 stretch-updates InRelease
Hit:5 stretch Release
Reading package lists… Done
W: Failed to fetch FailReason: ConnectionRefused
W: Some index files failed to download. They have been ignored, or old ones used instead.

This is hidden when running the script because the output from apt update is redirected to /dev/null

Works now. No IPv6 support for Just checked it’s 2018. :frowning: