Installing Gitlab using Ansible on VMs

Hi, I want to install Gitlab with 5k architecture on Rhel8 VMs, I have already provisioned the VMs and tested that they are reachable and can communicate with one another, and I’m using the GET tool.

although the consul nodes are configured, they are not forming a cluster, one node is returned when running the command to get consul nodes. I tried the workarounds mentioned in the troubleshooting part of the GitLab documentation but in vain.

Any help will be appreciated. thanks

Perhaps you can link what documentation you have been following to install and configure Gitlab? Especially for the ansible stuff as well for deploying this?

Based on what you have written so far, it’s impossible to help without you providing more detail.

I followed those steps and used the playbooks of the GET tool.

for the issue I’m facing (failed to sync remote state: No cluster leader) I tried:
adding bind_addr, restarting consul and Recreate from scratch.

Not sure if these posts might help, when searching for the failed to sync remote state:

And also this from Gitlab docs:

instead of the recreate from scratch.

The only other thing that springs to mind is that RHEL by default has firewalld running - perhaps this isn’t disabled, or perhaps the ports have not been opened up on firewalld and consul cannot communicate because of this? Hope some of those links help, as there are some consul ideas there that might help with that particular error.

Thank you @iwalker. I will test those solutions

1 Like