Issue with installing Gitlab on ubuntu server 14.04 (with Apache server)


I’m trying to install Gitlab (without omnibus) on my Ubuntu server 14.04 along with Apache. I faced several issues and I was able to debug most of them. However, I’m having issues with installing Ruby gems which I just cannot seem to solve.

I’m following this to install. I was able to install ruby, Gitlab shell, DB successfully. Im at the step where I have to do the below.

sudo -u git -H bundle install --deployment --without development test postgres aws

I get Could not find modernizr-2.6.2 in any of the sources. I then tried this but it looks like that page/download is no longer available. I then tried bundle install and even that does not work.

Running sudo -u git -H bundle exec rake gitlab:env:info RAILS_ENV=production gives me the following error

Could not find rake-10.1.0 in any of the sources
Run bundle install to install missing gems.

I have tried almost everything available on the internet and things still don’t work. I was guessing that the problem was the missing gem modernizr-2.6.2 and I tried installing it from here using

gem install modernizr-rails -v 2.6.2

when i run sudo -u git -H bundle exec rake gitlab:env:info RAILS_ENV=production after the above I still get the same errors.

I checked the list of local gems installed and it looks like modernizr-rails -v 2.6.2 was installed
gem list gave me this

bigdecimal (1.2.0)
bundler (1.10.6)
charlock_holmes (
io-console (0.4.2)
json (1.7.7)
minitest (4.3.2)
modernizr-rails (2.6.2)
psych (2.0.0)
rake (0.9.6)
rdoc (4.0.0)
test-unit (

How can I resolve this?

Did you get your issue resolved. I am in same boat and stuck on this step since quite a long time.

Nobody replied on my question as well. As if nobody cares about this error. Is it so simple ? am I missing something ?

@agm @deepeshmittal First off, we recommend OmniBus for installation of GitLab. If you are on source, please try to move to OmniBus

GitLab OmniBus comes bundled with its own Nginx.

  • To use an non-bundled web server, please follow this guide: This helps us to:
    • Disable bundled Nginx
    • Set the user for the non bundled web server
    • Set the right GitLab WorkHorse settings if you are on Apache
    • Finally, Provides a link to download the specific config files for your appropriate external server in this case Apache
1 Like