Kubernetes Integration on existing cluster fails

kubernetes
ci

#1

Hi,

I am trying to integrate GitLab CI with my existing Kubernetes cluster. I already have Helm/Tiller installed on that cluster and I have apps apps running already there (with Helm) with my previous CI system. Now I am migrating everything to GitLab and having trouble connecting the cluster. Following the docs: https://docs.gitlab.com/ee/user/project/clusters/ it says I am supposed to install Helm/Tiller (even though I already have that since I have been using it before migrating to GitLab). Clicking on “Install” button fails (expected?) without any useful error message: " Something went wrong while installing Helm Tiller * Kubernetes error.". I verified and ca.crt and token I priveded to GitLab are valid with correct role bindings.

So the question is… am I supposed to “Install” Heml/Tiller on a cluster that already has them installed? If so then how to fix this? I am running self-hosted GitLab 11.5.3-ee

Thanks!
Lukasz

UPDATE: I created a fresh HWA Kubernetes cluster (no Helm/Tiller) and tried using my self-hosted instance to deploy Tiller but that failed with the same error. Then I tried using gitlab.com hosted account to integrate with my cluster and it worked like a charm. Was there any bug in 11.5.3-ee that affects this? I will need more info about that to provide to my IT department in order to issue GitLab instance update. Thanks!