LFS upload not working to GitLab (error="handleStoreLFSObject: copy body to tempfile: ETag mismatch.")

Hi all,

I have set up GitLab on Docker with NGINX as reverse proxy. This works since months. Currently GitLab CE 11.

Yesterday I creates a docker Minio Azure Gateway container on another docker host. I can use this service over net without problems. I see all files in Azure & Minio Browser. (Minio is also behind an NGINX reverse proxy)

I changed GitLab config to support LFS. I used the tool to reconfigure it.

I created a test project with PNG as LFS tracked file type. I added the remote repository and installed LFS locally in the project, added .gitattributes and pushed it. THEN I added an PNG and tried to push it.

It only worked for one single file “page.png” in the first test.

After that file I added more. Now I get this error in the GitLab server.

> ==> /var/log/gitlab/gitlab-workhorse/current <==
> 2018-07-09_06:38:46.04796 time="2018-07-09T06:38:46Z" level=error msg=error error="handleStoreLFSObject: copy body to tempfile: ETag mismatch. expected \"1d66a52f517ea5469f71f9eed0aa7e2c\" got \"0x8D5E5669F06B013-1\"" method=PUT uri=/dev/lfs-test4.git/gitlab-lfs/objects/a5804e8db7d9dd8e899333657c741c6d9081c67196ce78ef6941b01ef296895d/2218
> 2018-07-09_06:38:46.04801 git.example.com @ - - [2018/07/09:06:38:46 +0000] "PUT /dev/lfs-test4.git/gitlab-lfs/objects/a5804e8db7d9dd8e899333657c741c6d9081c67196ce78ef6941b01ef296895d/2218 HTTP/1.1" 500 22 "" "git-lfs/2.4.2 (GitHub; linux amd64; go 1.8.3)" 0.148
> ==> /var/log/gitlab/nginx/gitlab_access.log <==
> - username [09/Jul/2018:06:38:46 +0000] "PUT /dev/lfs-test4.git/gitlab-lfs/objects/a5804e8db7d9dd8e899333657c741c6d9081c67196ce78ef6941b01ef296895d/2218 HTTP/1.0" 500 22 "" "git-lfs/2.4.2 (GitHub; linux amd64; go 1.8.3)"

I tried the same with git clients on windows and ubuntu. - git lfs client is installed.

Any ideas?


I tried “background upload” and it worked. “Direct upload” does not work.

I have created an “Issue”: