Memory starvation on RPi3 with Jessie


#1

Since after couple of minutes running gitlab-ce memory allocation rises up to 973MB (even without running gitlab-ci-multi-runner) I’m looking for a way to decrease memory usage. Any tips?


#2

Try to reduce the number of workers, see https://gitlab.com/gitlab-org/omnibus-gitlab/blob/master/doc/settings/unicorn.md#unicorn-settings


#3

Thanks but it is not doing the trick. I’ve reduced the number of workers to 1 and the memory allocation is still the same. Looking at the list of running processes sidekiq is take a lot of memory but apparently reducing the number of instances doesn’t help much either.


#4

A small update: the reduced number of workers actually works contrary to my previous post. It seems that restarting gitlab using gitlab-ctl isn’t the right solution to clean up all memory leaks. Instead the memory allocation is smaller after complete reboot.

Unfortunately after some time or usage the memory allocation is going up quickly up to 973MB again.

Maybe it will be useful to other Rpi fans.


#5

Hey,

Were you able to reduce the memory usage for Gitlab?

Thanks!


#6

Have you tried decreasing SIDEKIQ_MEMORY_KILLER_MAX_RSS.