New user e-mail invite not working

I’m using GitLab 7.10.0 on CentOS 7
I’m creating new users and expect them to get an e-mail invite to login and set the password.
The first user received an e-mail.

then i changed the ‘external_url’ in gitlab.rb file to an IP address, since this server is not in our DNS and ran ‘gitlab-ctl reconfigure’. I also configured HTTPS (with self-generated certs).

The server seems to be working, but no emails are going out.
If i get it right, default behavior is to use sendmail. I checked it from the OS/shell and it works.

Anyone knows where i can check GitLabs sendmail configurations and see if it is getting called ?

What command did you use to send the e-mail and what was the sender’s e-mail?

sudo sendmail
testing with sudo

From: root root@B12OPSGTLB01T.localdomain
testing with sudo

p.s. I also sent from my unprivileged user ‘mrudd’, but that one took a bit longer to get to me:

From: mrudd@B12OPSGTLB01T.localdomain

Found an Answer (thanks to Google Groups): “The problem I had was, that as soon as I configured one of the commented options it failed sending e-mails - even if set to empty. So the cure was not even to define them. Maybe you could try this with your config too.”
I followed his suggestion and here is my configuration:

gitlab_rails[‘smtp_enable’] = true
gitlab_rails[‘smtp_address’] = “
gitlab_rails[‘smtp_port’] = 25
gitlab_rails[‘smtp_enable_starttls_auto’] = false
gitlab_rails[‘openssl_verify_mode’] = “none”

everything else left commented out. Received an e-mail invite as soon as i created a new user.

Hmm it should work without the smtp settings, but glad that you worked it out.

as long as we are on the subject, if i may offer a suggestion - it would be nice to have an e-mail configuration option on the Admin UI, so that an administrator could configure and send a test e-mail from the UI and know if it works without having to play with the .rb files and ‘reconfigure’

1 Like

I thought about this feature myself, too. Discourse has it. It would be cool if you opened a request in


BTW, i noticed a number of topics marked as [SOLVED]. How do i do that to this topic? or do i not have that privilege ? I don’t see anything on the screen that would suggest i can change the topic’s status.

I simply edit the title :smile: