NoCredentialProviders error when trying to autoscale CI/CD with AWS Fargate

I’ve tried following this gitlab tutorial for autoscaling ci/cd with aws fargate and at the moment, I keep seeing these persistent error logs every time I push and Gitlab tries to run a pipeline:

INFO[2023-10-13T14:46:10Z] Starting fargate                              PID=1871493 version="0.3.0 (c55766a)"
INFO[2023-10-13T14:46:10Z] Executing the command                         PID=1871493 command=config_exec
Using Custom executor with driver fargate 0.3.0 (c55766a)...
INFO[2023-10-13T14:46:10Z] Starting fargate                              PID=1871501 version="0.3.0 (c55766a)"
INFO[2023-10-13T14:46:10Z] Executing the command                         PID=1871501 command=prepare_exec
INFO[2023-10-13T14:46:10Z] Starting new Fargate task                     PID=1871501 command=prepare_exec
ERRO[2023-10-13T14:46:10Z] Application execution failed                  PID=1871501 error="starting new Fargate task: running new task on Fargate: error starting AWS Fargate Task: NoCredentialProviders: no valid providers in chain. Deprecated.\n\tFor verbose messaging see aws.Config.CredentialsChainVerboseErrors"
WARNING: Cleanup script failed: exit status 2

The tutorial linked above appears to be a bit out-of-date, but I assumed it wouldn’t be too difficult to apply to the current state of AWS and Gitlab, and now I’ve hit a wall. Any and all advice or help is appreciated, as I’m relatively new to all this stuff. I’ve tried a few different solutions including adding the keys of one of the AWS IAM users for my organization to the project settings as shown in the “Authenticate Gitlab with AWS” section on this page, but nothing appears to work. Thanks in advance!