Pages stuck on deploy


I am on, for a private directory.
Repo is a flavor of Gatsby (docz)
The build stage is successful.
Artifact is produced, seemingly ok (link internaly are brokem but index is loading when I go and browse the artifact).
But the deploy is stuck.
I have tried to relaunch the pipeline, to remove etc.
But without much success.

  • CI configuration.gitlab-ci.yml
image: node:10.20.1

    - master
    - npm install
    - npm run build 
    - mv .docz/dist/* public/
      - public
      - node_modules

Any idea?

Same here, created a new repo and stuck on deploy, tried deleting and recreating it and still the same issue. I even made another repo just to test and same thing. Just stuck on deploying.

I’m also experiencing this since the issues on the GitLab platform yesterday evening. The pages:deploy task does appear to deploy, but then never mark as success. Does this mean our free CI minutes are being consumed when these jobs hang?

This seems to have been fixed for me in the past hour or so. I’ve not had it occur on my most recent builds.

Yup, seems to be fixed for me as well, thank you for letting me know @davidwinter