[partially solved] Install gitlab_7.8.0-omnibus on Ubuntu 14.04 with Plesk 12.0.18

I have a virtual server with Ubuntu 14.04 and plesk 12.0.18. The top level domain runs a wordpress blog. I would like to use this blog in the future. I would like to define a subdomain gitlab.myserver.de where i can use gitlab. At the moment i am not able to see any gitlab web content.

I used the Omnibusinstall dpkg -i gitlab_7.8.0-omnibus-1_amd64.deb. Now i need help to configure plesk and/or apache and/or nginx and/or gitlab to be able to use gitlab.

I did not find any specific information about my problem so far.

If you have any suggestions for me i would be pleased to read them.

It turns out that i get a result after restarting the nginx service:

:~# service nginx restart
* Restarting NGINX nginx
nginx: [emerg] bind() to failed (98: Address already in use)
nginx: [emerg] bind() to failed (98: Address already in use)
nginx: [emerg] bind() to failed (98: Address already in use)
nginx: [emerg] bind() to failed (98: Address already in use)
nginx: [emerg] bind() to failed (98: Address already in use)
nginx: [emerg] still could not bind()

Now my old plesk configuration web services are gone(404) but i do get the login page from gitlab at http://git.mydomain.de.

I think that i already had a nginx service running in my apache plesk configuration when i was installing gitlab. After the installation according to Installation for Ubuntu 14.04 i had to restart the already running nginx service because nginx needed to reload the configuration files provided by gitlab. The bad side is that i have to find and recover my original nginx configuration files now. Then i will try to create a setup where both plesk and gitlab may coexist together.

Any help will still be appreciated.

GitLab uses it’s own bundled nginx server. See https://gitlab.com/gitlab-org/omnibus-gitlab/blob/master/doc/settings/nginx.md#using-a-non-bundled-web-server for how to use your external nginx or apache.

I already read the page you sent me. Unfortunately i have a set of problems. The initial one is solved. My virtual server configuration had an apache2 and nginx already installed. After the gitlab installation i got another nginx instance with own configuration files in /var/opt/gitlab/nginx/conf/. So i got confused about all the different configuration files and instances.

At the moment i have disabled the native nginx of my machine and enabled the gitlab nginx. I use

external_url 'http://git.cpetzold.de:81'

in /etc/gitlab/gitlab.rb .

This way i am able to access both http://cpetzold.de and http://git.cpetzold.de:81. 1 through apache which listens on port 80 and 2 through gitlabs nginx.

But i did get 500 and 502 HTTP-error messages and i found out that the postgresql service crashed continuously. I had to set an option in /etc/sysctl.conf:

kernel.shmmax = 285646848

Than i had to load the value via

sysctl -p

Finally i got both web services running.

1 Like