Permission denied (publickey) after 429 (too many requests) error

Excuse me I have a trouble while working with a repo, when I run “git pull” command it throws this error.
I don’t know why this is happening because the repo worked perfectly few hours before, the repo exists, I just pulled it 2 hours ago. Normally I’d restart and clone the repo again, but now I have a docker tunnel to the repo so I think restarting it won’t be a great idea.
Some more info: before this error, while I was doing the pulls another error appeared for a few moments (429 too many requests) I don’t know if this was the principal problem, but I just waited and then I got the permission denied error.

Is there any way to recover the control or is it necessary to restart everything?. Thanks for any help.

Based on the error message 429 too many requests, I believe you’re hitting a rate limit:

The rate limits for can be found here:

Yeah, and as the doc says I waited and the error disappeared, the problem Is the “permission denied” error, I just mentioned the 429 because I thought it could be related, but now I don’t think so.
Thanks anyway.