Pipeline job failing. Local binary "not found"

I’ve been trying to get my pipeline working, and part of the process is downloading and using butler. However, even though it is listed in ls and I can chmod it, it still fails with “not found”. However, other scripts still work:

$ ls -la
total 17668
drwxr-xr-x    2 root     root          4096 Nov  3 06:58 .
drwxrwxrwx    7 root     root          4096 Nov  3 06:58 ..
-rwxr-xr-x    1 root     root       2291392 Oct 19 12:53 7z.so
-rwxr-xr-x    1 root     root      15590512 Oct 19 12:53 butler
-rwxr-xr-x    1 root     root        174240 Oct 19 12:53 libc7zip.so
$ chmod +x ./butler
$ ls -la
total 17668
drwxr-xr-x    2 root     root          4096 Nov  3 06:58 .
drwxrwxrwx    7 root     root          4096 Nov  3 06:58 ..
-rwxr-xr-x    1 root     root       2291392 Oct 19 12:53 7z.so
-rwxr-xr-x    1 root     root      15590512 Oct 19 12:53 butler
-rwxr-xr-x    1 root     root        174240 Oct 19 12:53 libc7zip.so
$ echo 'echo test' > test.sh
$ chmod +x test.sh
$ ls -la
total 17676
drwxr-xr-x    2 root     root          4096 Nov  3 06:58 .
drwxrwxrwx    7 root     root          4096 Nov  3 06:58 ..
-rwxr-xr-x    1 root     root       2291392 Oct 19 12:53 7z.so
-rwxr-xr-x    1 root     root      15590512 Oct 19 12:53 butler
-rwxr-xr-x    1 root     root        174240 Oct 19 12:53 libc7zip.so
-rwxr-xr-x    1 root     root            10 Nov  3 06:58 test.sh
$ ./test.sh
test
$ ./butler -V
/bin/sh: eval: line 90: ./butler: not found
ERROR: Job failed: exit code 127

I am using the node:11-alpine image as a base.

Did you end up finding a solution for this? I think I have a similar issue: /bin/sh: eval: line 97: ./mybinary not found