Postgresql replication

Hi guys, did anyone tried to set up a postgresql replication on a Community version.
Is it even supported in Community version?

That’s what I’ve tried:

gitlab.rb on main server:

postgresql[‘listen_address’] = nil
postgresql[‘port’] = 5432
postgresql[‘wal_level’] = “logical”
postgresql[‘max_wal_senders’] = 5
postgresql[‘max_replication_slots’] = 2
postgresql[‘sql_replication_user’] = “gitlab_replicator”
postgresql[‘sql_replication_password’] = “xxxxxxxxxxxxxxxxx”
postgresql[‘custom_pg_hba_entries’] = {
REPLICATION: [ # APPLICATION should identify what the settings are used for
type: “host”,
database: “gitlabhq_production”,
user: “gitlab_replicator”,
cidr: “”,
method: “md5”,

Then the replication inself:
on git1
sudo -u gitlab-psql /opt/gitlab/embedded/bin/psql -h /var/opt/gitlab/postgresql/ gitlabhq_production
CREATE ROLE gitlab_replicator LOGIN PASSWORD ‘Diasoft1’ SUPERUSER VALID UNTIL ‘infinity’;

on git2:
sudo -u gitlab-psql /opt/gitlab/embedded/bin/psql -h /var/opt/gitlab/postgresql/ gitlabhq_production
CREATE SUBSCRIPTION gitlab CONNECTION ‘host= dbname=gitlabhq_production user=gitlab_replicator password=password port=5432’ PUBLICATION gitlab;

Commands seems to be accepted, no errror but also no replication happens when I make changes on git1.

There are error in the logs

LOG: logical replication apply worker for subscription “gitlab” has started
could not connect to the publisher: could not connect to server: Connection refused
Is the server running on host “” and accepting
TCP/IP connections on port 5432?