Problem installing GitLab ("Disk quota exceeded") using Docker on QNAP

Hi there,

I want to use GitLab CE on my new QNAP server. There I tried to use Docker to get GitLab running.
I used the following docker compose:
and ran
docker-compose up

First it starts to run smoothely pull all packages and creates the images but then GitLab starts to throw the following error message during setup:

gitlab_1      | Initializing logdir...
gitlab_1      | chown: changing ownership of '/var/log/gitlab/nginx': Disk quota exceeded
root_gitlab_1 exited with code 0

So installation is not successfull.
Do you have any idea how to resolve this issue?

There is plenty of disk space left.


Maybe this is usefull:

[~] # docker ps -a --size
CONTAINER ID        IMAGE                         COMMAND                  CREATED             STATUS                         PORTS                                                   NAMES                 SIZE
fd8a159f9c0c        sameersbn/gitlab:8.9.6-1      "/sbin/ "   16 minutes ago      Restarting (1) 2 minutes ago   443/tcp,>22/tcp,>80/tcp   gitlab_gitlab_1       0 B (virtual 748.1 MB)
bb1fb127335a        sameersbn/postgresql:9.4-23   "/sbin/"    16 minutes ago      Up 16 minutes                  5432/tcp                                                gitlab_postgresql_1   0 B (virtual 239.9 MB)
9217875c4f6b        sameersbn/redis:latest        "/sbin/ "   16 minutes ago      Up 16 minutes                  6379/tcp                                                gitlab_redis_1        0 B (virtual 203.4 MB)

I continued to search the reason for my problem.

At least I was able to find the origin of the error message:

To me it looks like things can be done as root without problems, but as soon as commands are executed as ${GITLAB_USER}:, the error message “Disk quota exceeded” starts to pop up.
So there seems to be a problem with the user.

Hi there,

found some more information.
I was able to get into the docker (via SSH on my QNAP) by running

docker run -it sameersbn/gitlab:8.9.6-1 bash

8.9.6-1 is the most current version supported by QNAP

Next I just ran for testing the commands highlighted above

mkdir -p ${GITLAB_LOG_DIR}/nginx
chmod -R 0755 ${GITLAB_LOG_DIR}/nginx
chown -R ${GITLAB_USER}: ${GITLAB_LOG_DIR}/nginx

First two are working well BUT again the third is throwing the very same error message

chown: changing ownership of '/var/log/gitlab/nginx': Disk quota exceeded

I was playing around for a while and the user git is just not allowed to create anything at all on this volume.

Anyone knows why? How to resolve this?
Please help! I am trying to get this to run for days already.