Projects in a group refuse to use the GitLab shared runners

I just moved a project from my personal ownership into a group, and now the project refuses to use GitLab shared runners. All jobs are stuck pending forever no matter what. The project Settings > CI/CD page lists out 15 different GitLab shared runners, but that same settings page in the group does not have any in the list.

How does this work? How can I get all projects in the group to use GitLab runners?

Hi @wf-chris

If shared runners were working for you before, then presumably you had Enable shared runners in your project You also need to go to and turn on Enable shared runners.

That should really be all you need, and it’s worked for me when I’ve moved projects around.

If you’ve already done that, then I’m not sure what to suggest. It seems unlikely that the problem would be with your .gitlab-ci.yml file, but I suppose it’s not impossible…

Thanks, I did indeed have shared runners enabled and that still wasn’t working.

I just ended up deleting and re-creating the project, this time from the group screen directly and that worked. Wasn’t a big deal since this was a fresh new project anyway.

Weird bug though. Maybe something to do with this?