Push speed capped to 10KiB/s


As stated in the title, my speed push is capped to 10KiB/s.

It for days now and becoming annoying, I tried to google it and found some advices such settings these :
gc.auto true
core.fscache true
core.preloadindex true
https.postbuffer 524288000 (or http instead of https)
… but these seems not to work for me.
Also I re-installed git with the newest version.

I tried to push my local repo in a new project, same issue.

Exiting my anti-virus (Kapersky free) would speed it up for seconds and made “fatal: The remote end hung up unexpectedly”.

I am using git bash on windows 10 and I didn’t noticed any speed issue on others softwares so I don’t think it is related to my connection.

I tried to push on github, same issue, so might not be related to the server.

I used git bash for some weeks without problem and I didn’t touched the configuration before that issue started.

By the way, I am quite a noob about git thus I don’t know what to do about this.

Any advice ? Did someone had and fixed this issue ?


No one after a week ? :’(