Pushing To Docker Registry From .gitlabci doesn't work

Everything worked before gitlab crashed but now it’s not working,

Now I’m having errors when trying to push containers to the gitlab registry (logs):
e[32;1m$ docker-compose -f docker-compose.build.yml pushe[0;m
Pushing zzzzzz (registry.gitlab.com/xxxxxxxx/yyyyyy/zzzzzz:latest)…
The push refers to repository [registry.gitlab.com/xxxxxxxx/yyyyyy/zzzzzz]
Traceback (most recent call last):
File “/usr/lib/python3.8/site-packages/urllib3/response.py”, line 437, in _error_catcher
File “/usr/lib/python3.8/site-packages/urllib3/response.py”, line 519, in read
data = self._fp.read(amt) if not fp_closed else b""
File “/usr/lib/python3.8/http/client.py”, line 458, in read
n = self.readinto(b)
File “/usr/lib/python3.8/http/client.py”, line 492, in readinto
return self._readinto_chunked(b)
File “/usr/lib/python3.8/http/client.py”, line 587, in _readinto_chunked
chunk_left = self._get_chunk_left()
File “/usr/lib/python3.8/http/client.py”, line 555, in _get_chunk_left
chunk_left = self._read_next_chunk_size()
File “/usr/lib/python3.8/http/client.py”, line 515, in _read_next_chunk_size
line = self.fp.readline(_MAXLINE + 1)
File “/usr/lib/python3.8/socket.py”, line 669, in readinto
return self._sock.recv_into(b)
File “/usr/lib/python3.8/ssl.py”, line 1241, in recv_into
return self.read(nbytes, buffer)
File “/usr/lib/python3.8/ssl.py”, line 1099, in read
return self._sslobj.read(len, buffer)
socket.timeout: The read operation timed out

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/usr/bin/docker-compose”, line 11, in
load_entry_point(‘docker-compose==1.25.4’, ‘console_scripts’, ‘docker-compose’)()
File “/usr/lib/python3.8/site-packages/compose/cli/main.py”, line 72, in main
File “/usr/lib/python3.8/site-packages/compose/cli/main.py”, line 128, in perform_command
handler(command, command_options)
File “/usr/lib/python3.8/site-packages/compose/cli/main.py”, line 759, in push
File “/usr/lib/python3.8/site-packages/compose/project.py”, line 699, in push
File “/usr/lib/python3.8/site-packages/compose/service.py”, line 1262, in push
return progress_stream.get_digest_from_push(
File “/usr/lib/python3.8/site-packages/compose/progress_stream.py”, line 112, in get_digest_from_push
for event in events:
File “/usr/lib/python3.8/site-packages/compose/progress_stream.py”, line 25, in stream_output
for event in utils.json_stream(output):
File “/usr/lib/python3.8/site-packages/compose/utils.py”, line 61, in split_buffer
for data in stream_as_text(stream):
File “/usr/lib/python3.8/site-packages/compose/utils.py”, line 37, in stream_as_text
for data in stream:
File “/usr/lib/python3.8/site-packages/docker/api/client.py”, line 345, in _stream_helper
data = reader.read(1)
File “/usr/lib/python3.8/site-packages/urllib3/response.py”, line 541, in read
raise IncompleteRead(self._fp_bytes_read, self.length_remaining)
File “/usr/lib/python3.8/contextlib.py”, line 131, in exit
self.gen.throw(type, value, traceback)
File “/usr/lib/python3.8/site-packages/urllib3/response.py”, line 442, in _error_catcher
raise ReadTimeoutError(self._pool, None, “Read timed out.”)
urllib3.exceptions.ReadTimeoutError: HTTPSConnectionPool(host=‘docker’, port=2376): Read timed out.
e[0Ke[0Ke[36;1mCleaning up file based variablese[0;m
e[0Ke[31;1mERROR: Job failed: exit code 1

Some of my jobs are failing for no apparent reasons and the builds have been dead slow. We are seeing similar issues with this OP.

1 Like

They had issues with the docker registry but they fixed it :slight_smile: