Rake gitlab:indexer:install not found

When running sudo -u git -H bundle exec rake "gitlab:indexer:install[/home/git/gitlab-elasticsearch-indexer]" RAILS_ENV=production it returns:
rake aborted! Don't know how to build task 'gitlab:indexer:install' (See the list of available tasks with rake --tasks) Did you mean? gitlab:shell:install
if I run bundle exec rake --tasks (have tried with RAILS_ENV=production as well, no luck) it crashes with a long errror: https://pastebin.com/UV8FJBKm
The install guide says to use that command, yet it’s not found.
I’m trying to install version 12.6 (edit: from source)
If I run
I have tried to figure this out, but was unable, help would be appreciated.

@diademiemi ,

I am also facing same issue.

Are you able to fix this issue? If yes, can you please help me?


I have the same issue with 13-0-stable doing the source install. It is a shame that this issue is not yet addressed in the installation guide.

Here is a workaround to get the correct version for elasticsearch indexer:

For 13-0-stable the last line would read:

  • git checkout -b v2.2.0 v2.2.0

Finally end with

  • make
1 Like