Remote host closes connection prematurely

Hey guys,

Today when I tried to push some new updates to my private project, somehow the remote host is not allowing me to push or pull the contents. When I tried to ssh, I can see that remote host is breaking the connection just after the key exchange. Here is the debug details.

ssh -vvv
OpenSSH_6.2p2, OSSLShim 0.9.8r 8 Dec 2011
debug1: Reading configuration data /etc/ssh_config
debug1: /etc/ssh_config line 20: Applying options for *
debug1: /etc/ssh_config line 102: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to [] port 22.
debug1: Connection established.
debug1: identity file /Users/subinhutton/.ssh/id_rsa type -1
debug1: identity file /Users/subinhutton/.ssh/id_rsa-cert type -1
debug3: Incorrect RSA1 identifier
debug3: Could not load “/Users/subinhutton/.ssh/id_dsa” as a RSA1 public key
debug1: identity file /Users/subinhutton/.ssh/id_dsa type 2
debug1: identity file /Users/subinhutton/.ssh/id_dsa-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.2
ssh_exchange_identification: Connection closed by remote host

Is there any issues now?

This is now resolved.