Repo not found


#1

git push origin master
remote: The project you were looking for could not be found.
fatal: repository ‘https://gitlab.com/xxx_yyy_zzzz/dd-eee.git/’ not found

The repo is there. I want to use https (not shh) so everything seems like it it’s config’ed correctly, etc. Yet no matter what I try, I get this error. It’s been over an hour of running around in circles (wasting time).

Note: Normally I would use ssh but in this case with this project / client I want to use un + pw to push.

Help. Please. TIA.


#2

@client_dd3 can you pull from that repo to your local machine?

What happens when you try to re-add it as a remote or run git remote -v in the project directory on your local machine?


#3

I’ve tried to clone it. Same error.

Tried to pull. Same error.

I’m at a complete loss on what else to try. It’s there - empty - but there. But can’t get to it.


#4

The group and repo were both private - which is necessary once the repo is populated. I switch them both to public and was able to clone. So I guess there’s a global git config setting I need to change?

But what isn’t it just prompting me for user name and pw?


#5

I think that you’re correct regarding global git config on the local machine - I would expect it to be required to hit the private repo with the credentials of a user with permission in that project.

This could also be because you’re using HTTPS as well. I’m curious on this one, I’m going to check out the docs some more.

Glad you got the access!


#6

@jamesmundia - thanks for your help.

Here’s some more info: I opened a new BitBucket account. I was able to push to a private repo on BB. I was also prompted for the creds. Point being, this is starrting to feel like a GL issue, and not my end. Yeah, I agree, it might be some setting / config issue on my end. But if that’s the case, GL should doc that, or somehow point it out to me. Right?

Any new ideas?


#7

@jamesmundia - Bingo! I think I got it. Evidently, there’s something called Windows Credentials. I’ve used Win for a long time and this is the first time I’ve been made aware of it. In any case, it was mentioned here:

and then used this:

I did have something stored - that I wasn’t aware of - for GitLab. I deleted that and it looks like everything is okay.

No offense to GL or MS but this is bullshit. There’s not way something this simple (?) should take so many minutes/hours over too many (work) days. Crazy! Stupid but still crazy.

In any case, thanks again for trying to help. Much appreciated.


#8

Glad you sorted it out!

Best of luck with your projects,

J