Restore failing

Hello everyone. I hope all is well.

I’ve tried (many times now) to restore a backup of my GitLab 10.3 (10.2 the other day) on a different server (even tried two different servers) to no avail.

It will unpack and get through over 500 projects, but then fails with roughly 50 remaining.

These are the last few lines before (just in case it’s important, on the server I made the back-up in, I had to add another volume (as the original was running out of space – not sure if that plays a role):

************************ … [DONE]

  • ************************ … [DONE]
  • ************************ … [DONE]
  • ************************ … [DONE]
  • ************************ … rake aborted!
    TypeError: no implicit conversion of nil into String
    /opt/gitlab/embedded/service/gitlab-rails/app/models/repository.rb:97:in join' /opt/gitlab/embedded/service/gitlab-rails/app/models/repository.rb:97:in path_to_repo’
    /opt/gitlab/embedded/service/gitlab-rails/lib/backup/repository.rb:145:in path_to_repo' /opt/gitlab/embedded/service/gitlab-rails/lib/backup/repository.rb:79:in block in restore’
    /opt/gitlab/embedded/service/gitlab-rails/lib/backup/repository.rb:77:in restore' /opt/gitlab/embedded/service/gitlab-rails/lib/tasks/gitlab/backup.rake:88:in block (4 levels) in <top (required)>’
    /opt/gitlab/embedded/service/gitlab-rails/lib/tasks/gitlab/backup.rake:61:in block (3 levels) in <top (required)>' /opt/gitlab/embedded/bin/bundle:23:in load’
    /opt/gitlab/embedded/bin/bundle:23:in `’
    Tasks: TOP => gitlab:backup:repo:restore
    (See full trace by running task with --trace)

Thank you for any insight you can provide.