Runner successfully builds, but still runs on

I have the following yml file:

  - build
image: tvl/gitlab-node-runner:latest
  stage: build
    - 'npm install'
    - 'ng build --prod'
    - 'docker build -t tvl/asgard .'
    - 'ps'

This finishes all the above actions without incident, but the build is still left as ‘Running’ afterwards, forcing me to cancel it and restart the runner in docker. The log ends with:

Time: 17742ms
chunk    {0} polyfills.2d45a4c73c85e24fe474.bundle.js (polyfills) 158 kB {4} [initial] [rendered]
chunk    {1} main.d8efb39cb35fc9a55d36.bundle.js (main) 69.2 kB {3} [initial] [rendered]
chunk    {2} styles.dbfc2b033acc59bb319f.bundle.css (styles) 69 bytes {4} [initial] [rendered]
chunk    {3} vendor.0d3d64c793f45b4d7693.bundle.js (vendor) 1.9 MB [initial] [rendered]
chunk    {4} inline.164b3a3f930a3c22cf14.bundle.js (inline) 0 bytes [entry] [rendered]
$ docker build -t tvl/asgard .
Sending build context to Docker daemon 166.6 MB
$ ps
   PID TTY          TIME CMD
     1 ?        00:00:00 bash
     6 ?        00:00:00 bash
    50 ?        00:00:00 ps

Does anyone have any idea why this could be, or how I could debug this? It’s driving me nuts.

If I only do npm install and ps, it works fine. The introduction of ‘ng build’ is what causes this, but the command completes successfully and continues the rest if the script as you can see.

I’m still not quite sure why I had this issue, but adding --progress=false to my angular-cli command fixed it. I assume gitlab ci is none too happy with the kind of output it produces.