SAST spotbugs fails with exit status, but no obvious problem

I am using the SAST tools that come as part of GitLab Ultimate, but whenever it executes it errors out with no obvious message. The corresponding gl-sast-report.json artifact is not uploaded, so no results are available in the dashboard.

I’m using a self-managed GitLab, version 12.9.2-ee (0ad76f4d374). The output from the Job Log is:

Project built.
exit status 1
Error: SpotBugs analysis failed for /builds/group-name/project-name: exit status 1
Uploading artifacts... 
WARNING: gl-sast-report.json: no matching files

It takes 20 or so minutes between the “Project built.” part and the “exit status 1” part.

I’ve tried this with and without the SAST_DISABLE_DIND flag, same results in both cases. The spotbugs analyzer does work properly if I run it directly on my machine (not via a gitlab-runner). Adding a JAVA_OPTS for extra memory did not modify the results, either.

I tried forking the spotbugs analyzer and building a version without the “-quiet” flag, but that did not add any additional input.

Does anybody have an ideas on how to get more information about what’s failing? Better still if you can solve the problem, but I’ll certainly settle for more info…