Solved - Sudden Bad GPG signature

I can’t seem to find a solution for this and I’m nervous about breaking the install.
I cannot update gitlab and get turned at every try. This just suddenly happened and I’m not sure if it’s just something on the gitlab download end or at my end.

# sudo rpm -q gpg-pubkey --qf "%{name}-%{version}-%{release} --> %{summary}\n"
gpg-pubkey-6d745a60-60287f36 --> gpg(Release Engineering <>)
gpg-pubkey-51312f3f-621fa7a9 --> gpg(GitLab B.V. (package repository signing key) <>)
gpg-pubkey-f27eab47-62829ce6 --> gpg(GitLab, Inc. <>)

# sudo dnf update --refresh
Rocky Linux 8 - AppStream                                                                                                                                                                14 kB/s | 4.8 kB     00:00
Rocky Linux 8 - BaseOS                                                                                                                                                                   17 kB/s | 4.3 kB     00:00
Rocky Linux 8 - Extras                                                                                                                                                                  9.3 kB/s | 3.1 kB     00:00
gitlab_gitlab-ce                                                                                                                                                                        682  B/s | 862  B     00:01
gitlab_gitlab-ce                                                                                                                                                                         15 kB/s | 3.1 kB     00:00
gitlab_gitlab-ce                                                                                                                                                                         19 kB/s | 4.6 kB     00:00
gitlab_gitlab-ce                                                                                                                                                                        768  B/s | 862  B     00:01
Error: Failed to download metadata for repo 'gitlab_gitlab-ce': repomd.xml GPG signature verification error: Bad GPG signature

I’m not sure how to get out of this and hoping someone here knows.

It’s been solved already on the forums, search and you’ll find the posts.

another alternative is using the install command to add the repos again to your machine which will refresh the data. The example here is for deb based distro’s, but you can find the command for rpm based distros from the Gitlab docs install page:

for example:

curl | sudo bash

change ee to ce, if you are using a different version.

Yes, as mentioned, I searched.
Sometimes, you can search and search and never find something conclusive and I didn’t want to break the host so though it better to post.

Thank you for the response, I’ll check those out.