Some nuget packages are not getting pushed to the gitlab repository nuget packages


I am trying to push nuget packages to one of my repositories in gitlab.

Almost all the packages are getting pushed successfully except for few.

I have three versions of same package


The first one is not getting pushed while the rest two are pushing successfully.
While the output says that all the three versions are pushed successfully but it is always the last two versions.
And there is nothing wrong with the first one also, because I checked it pushing in my local nuget source and it works there.

See, it says all the packages are pushed successfully, but only pushes last two


Any help will be appreciated

I believe I am running into the same issue and wanted to see if there’s been a resolution to issue. I am pushing nuget packages to a test repo in gitlabs. It says the packages were successfully pushed but they don’t show up in the repo. I’ve followed the simple tutorial provided here

Any ideas why this isn’t working? Thank you in advance.

Same here…

I’m in the process of changing my builds to use the GitLab package registry, and my builds push the package successfully, but no packages appear in the GitLab GUI or when querying the GitLab NuGet repo via Visual Studio 2019 or other tools.

Manually pushing the package yields the same result - the push works, but nothing shows up.

The docs say “It can take up to 10 minutes to process a package”, but even after a few hours nothing shows up. It’s a NuGet black hole!

I figured out the problem, at least in my case and likely that of @timsong too.

GitLab’s NuGet repo doesn’t like version numbers with 4 components. See NuGet packages with extended versions fail to upload for details.

Hopefully they’ll fix this soon, but for now, I’ve changed the version number of my NuGet packages to leave out one component that wasn’t being used anyway.


Thank you @rosenqui! That was exactly the problem I was running into. I modified my build number to also remove one the of components and that worked like a charm. I see the packages available in Gitlab’s NuGet repo now. Much appreciated!

1 Like

Evening i’m new to GitLab, I ahve multiple projects (one per package) and a higher level group, which I have created a deployment user and token which i then used to configure my nuget.config file. but its failing to upload the packages to the group.

I can create deploy tokens per project but then I’m having to reconfigure my nuget.config file to push correctly to each project every time I work on a different project.

How did you guys work around this to ensure each package is pushed to its correct project space?



A few weeks ago we have upgraded our GitLab (on-prem free edition) to latest version and now we have this issue when NuGet Push says that package is getting pushed successfully, but it is not shown in our NuGet repository on GitLab server. Before this upgrade this was working fine. Has anybody have any suggestions what we could check where the problem is?