SSH into a shared runner's docker container

My gitlab-ci deployment gets stuck at Google Authentication process. In the logs I get instructions to visit a certain URL (has to be from the machine/container running the script) in this case the gitlab-ci runner.
Is there a way to ssh into the shared runner and run a ‘curl GET’ command request to fulfil the authentication process?
I can do this if I run the script and authenticate fine when I run "Curl GET … " on my local machine, but the not sure how I can get into the docker in gitlab-ci image running the script.
Your help is appreciated.

Any hints? any docker gurus?

Hi, I’m really far from being a guru, but I can try to help you.
Do you have access to the host where the runner container is created?
In such case you can search the container name with docker ps

When you get the name of the container you can try the following:
docker exec -it containername /bin/bash

hey thanks for trying to help,
the issue I’m facing is even being able to run any commands in the shared runner. I’m using hosted Gitlab shared runners.
described here:

ah sorry, I currently use a home server installation of gitlab and gitlab runner.
Can you share the content of your .gitlab-ci.yml file?
Does it show you an error?

It’s running ok, but the logs freeze at the point when google asks to visit an authentication URL from the local machine. and the build won’t continue past that point.
I thought I could
docker exec -it containername /bin/bash
like you’ve suggested, but there doesn’t seem to be a way to do that in a shared runner.