Timeout on artifact upload

Hi,

I have installed a new private Gitlab instance (release 12.0.2) using Debian packages.
I have included a Docker-based runner on the same server as Gitlab, and a CodeClimate job which produces a “codeclimate.json” file which I declared as an artifact; but artifact upload always fails with an error:

Uploading artifacts...
codeclimate.json: found 1 matching files                   
ERROR: Uploading artifacts to coordinator... error  error=couldn't execute POST against http://gitlab.dev-dsm.onf.fr/api/v4/jobs/158/artifacts?artifact_format=raw&artifact_type=codequality: Post http://gitlab.dev-dsm.onf.fr/api/v4/jobs/158/artifacts?artifact_format=raw&artifact_type=codequality: EOF id=158 token=Fs4hheWg
WARNING: Retrying...                                error=invalid argument

NgInx reports a 408 (timeout) error from gitlab-runner:

172.22.73.85 - - [28/Jun/2019:13:24:59 +0200] "POST /api/v4/jobs/153/artifacts?artifact_format=raw&artifact_type=codequality HTTP/1.0" 408 0 "" "gitlab-runner 12.0.1 (; go1.8.7; linux/amd64)"

I tried to reconfigure all timeout-related Gitlab settings to higher values (until five minutes !) in gitlab.rb, without success; I also tried to create another very small artifact file but the same error remains; the current timeout seems to remain of one minute!!

Any idea?

Regards,
Thierry

P.S. : my Gitlab instance is located behind an HTTP proxy; but every other requests (Docker or Gitlab related) always works perfectly; I installed a local Tinyproxy server, accessible from Docker network interfaces, which redirects requests internally or through another external proxy according to a small set of access rules; Tinyproxy logs indicate that everything is OK…

1 Like