Total Newb, 502 error on new installation on Ubuntu 20.04

Hey folks.

Prompted by copilot, I was looking to switch from github and on a bit of a whim I decided to try and install my own gitlab instance and set up a new empty 20.04 VPS to play with it on.

Followed all the instructions and everything seemed to go fine with no obvious errors. When I connect to the server through a browser I get a branded 502 page from nginx, so I assume that means it can’t talk to whatever the backend appserver is (my knowledge on this kind of stuff is 2008-era rails/mongrel, so I’m sketchy on the details).

I had a look in the nginx error_log and when I connect from Safari on my Mac I get:

SSL: error:141CF06C:SSL routines:tls_parse_ctos_key_share:bad key share

I tried the Qualys SSL test on the server and it seemed happy enough. Since Safari shows the branded 502 page without error, I’m assuming the SSL handshake problem is between nginx and gitlab, and not between Safari and nginx ?

Any ideas? I’m not even sure where to start looking (the curse of a big installer that does tons of stuff for me).

Any help appreciated.


facepalm. False alarm. The SSL errors were in the log from a while ago and do not appear every time I hit the page.

So… I still get a 502 but no way to understand why.

Updating as I go in case something leaps out at someone. I found the gitlab-workhouse logs as the next step in the chain from nginx.

I do see a fresh message here when I try and hit the site.

{"correlation_id":"01FAGQJYNG7GGCXZ7QRCN0R1MA","duration_ms":1308,"error":"badgateway: failed to receive response: dial unix /var/opt/gitlab/gitlab-rails/sockets/gitlab.socket: connect: no such file or directory","level":"error","method":"GET","msg":"","time":"2021-07-13T21:05:36+01:00","uri":"/"}

{"content_type":"text/html; charset=utf-8","correlation_id":"01FAGQJYNG7GGCXZ7QRCN0R1MA","duration_ms":11566,"host":"","level":"info","method":"GET","msg":"access","proto":"HTTP/1.1","referrer":"","remote_addr":"","remote_ip":"","route":"","status":502,"system":"http","time":"2021-07-13T21:05:43+01:00","ttfb_ms":11520,"uri":"/","user_agent":"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.1.1 Safari/605.1.15","written_bytes":2940}

and indeed /var/opt/gitlab/gitlab-rails/sockets/ is empty.

Tried running reconfigure in case I’d missed something and it kept hanging on “authorising Grafana with rails” so I set grafana enable=false in the gitlab.rb file and now reconfigure runs ok to completion, but still gives me same error in gitlab-workhorse.log :shrug:

I’ll wait and see if anyone replies tomorrow, but I’m pretty much at the limits of my available energy for digging more myself. Feels frustratingly close to working, but it was only a $4 VPS experiment so I can just throw it all away, :slight_smile: