Ubuntu apt, and upgarding to 13

I have gitlab installed on Ubuntu 18.04.4.

I have been keeping it up to date using apt. When I tried to run an upgrade this morning it wanted to install version 13, but refused because I was not at the latest patch version of 12.

I upgraded to the latest patch as follows: apt-get install gitlab-ee=12.10.6-ee.0

The next time I run apt-get upgrade I assume it is going to attempt to install 13 again, however I note that PostgreSQL 11 is a minimum requirement, which is not available. Is it time for me to remove gitlab from apt so I can continue to install security updates?

Thanks in advance for any help or advice.

Hi @mcconnors I had a similar problem on Ubuntu 18.04.04. Here’s what I did to resolve it:

  • upgrade to 12.10.6 (sounds like you already did this)
  • resolve any warnings in gitlab-ctl check-config or gitlab-rake gitlab:check
  • run gitlab-rake db:migrate, gitlab-ctl reconfigure, and gitlab-ctl restart
  • sudo apt update && sudo apt upgrade gitlab-ee -y
  • gitlab-ctl reconfigure

Let me how it goes either way!

It worked. Thanks for your help. What I was forgetting was that postgresql is bundled, so it doesn’t matter what is available in apt.

The upgrade was successful. Not sure if I I need to do some tuning now though, as my pipeline builds re failing from time to time and I’m needing a restart to fix them.

1 Like

If you’ve not already done so, I suggest upgrading any runners to version 13.0 as well. This should resolve any compatibility problems. You can check your runner versions at <external_url>/admin/runners. Let me know if this doesn’t resolve the issue you’re seeing with pipeline builds failing.

https://docs.gitlab.com/runner/#compatibility-with-gitlab-versions

My runners are at 13 already. It has been stable now since yesterday.