Unable to access repository: The requested URL returned error: 403

Hi, I have suddenly started getting error 403 whenever I try to communicate with the remote (clone, push, pull) with any project. I have tried with SourceTree, TortoiseGit and CLI. Same result for all three.

I have tried:

  • via HTTPS after clearing out the credential manager.
  • SSH key
  • Removing myself from the group and project and adding myself back to both

Not sure what else I can do? It always gives the following:

git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks push -v --tags origin mat:mat
Pushing to https://gitlab.com/.../....git
warning: Authentication error: Authentication required: Authorization error: https://gitlab.com/.../....git/info/lfs/locks/verify
Check that you have proper access to the repository

batch response: Authorization error: https://gitlab.com/.../....git/info/lfs/objects/batch
Uploading LFS objects:   0% (0/2), 0 B | 0 B/s, done.
Check that you have proper access to the repository
error: failed to push some refs to 'https://gitlab.com/.../....git'
Completed with errors, see above.

Please note I have censored the exact project URL as it is private.