Unable to clone private repo

I am trying to clone a private repo using git clone commad(git clone https://gitlab.com/sitiaisah.mohdnoor/week5.git) via git bash and have tried via github desktop as well.
both method are failing with error
remote: HTTP Basic: Access denied
fatal: Authentication failed for 'https://gitlab.com/sitiaisah.mohdnoor/week5.git/

I have set my password and able to login via browser successfully…so im sure my password is correct.
I have tried to use access token instead of password, but still failing.
I have tried editing or removing from windows credential but none worked.

please help.

Not sure how you are cloning, but you should be putting the username and token in the url, so:

git clone https://username:token@gitlab.com/sitiaisah.mohdnoor/week5.git

and that should work fine (obviously replace username with your login, and token with the token you generated). I do this with my private repos, works a treat.

Hi, thank you for the suggestion, I did tried and it does not work for me.
However, I have tried creating ssh key and cloning via that method instead.
That did it for me. Thank You.