Unable to clone / pull / fetch repository (ERROR: maximum time in concurrency queue reached)

When trying to fetch a repository using SSH my whole team gets the following error:
(Private repository shopiq/core)

15:38 $ git fetch
remote: ========================================================================
remote: ERROR: maximum time in concurrency queue reached

remote: ========================================================================
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

The issue started today at around 14.00 CET.
Other repositories in the same group work fine.

I tried doing the same thing from an ec2 server but with identical results.

Deleting and re-adding my ssh key did not change the result
Fetching via HTTP works fine, only ssh does not work since today 14.00 CET
After about 6 hours it works again.

Gitlab SSH is down again for our repository. Let’s see how long it takes this time to work again.

It seems that one of the core services provided by gitlab is continually not working.

A day later and it is still not working (or at least broken again)

A meeting later and it has started working again. Let’s see how long this holds …

And again git via SSH is not working for our repository with the same error again.

Seems like you are getting rate limited: Gitaly limits issue (#360661) · Issues · GitLab.org / GitLab · GitLab

Rate limits explained more here: GitLab.com settings | GitLab

We are a small team with only 5 persons and I would be very surprised if we consistently hit those rate limits which in turn would block ssh access to our repository from anywhere for any user for hours on end and therefore even blocking all of our CI pipelines.

(The only thing polling the git repository is our old jenkins with no more than 5 git fetches per minute everything else is done via gitlab pipelines.)

Is the only solution to switch to github.com or is there a way to make gitlab ssh consistently work for developers?

EDIT: I haven’t been able to do a single git fetch since last week thursday on our repository.

EDIT2: My current best guess is that the gitaly node hosting our repository is constantly overloaded which in turn produces these errors. If I find the time deleting and recreating our repository could move it to another node which would very probably fix most if not all of our problems.
But again - this should not be necessary for us to use gitlab.com via ssh.

Limits are IP-based, so if your 5 users, CI/CD and Jenkins are all from the same IP, then depending on how often your CI/CD is running, there is the potential it could exceed it.

I doubt deleting your repository will help. I expect that geo location via IP will choose which server you end up connecting to, so eg: your nearest Gitaly instance. In which case you’ll just end up re-creating it on the same server.

I can only guess that this is the situation, since it works, and stops working that the only explanation is your IP being rate limited or something else. Unless you have the ability to report this directly to Gitlab with opening a support ticket with them, then I guess we’ll just have to wait and see if it improves in the future. Unfortunately, free users cannot open tickets with Gitlab. Perhaps a Gitlab employee will appear here sometime soon and be able to help with this.

You could run your own installation of Gitlab it just depends on whether you want to do that or not. That way, you don’t have rate limits at all.

As said in the first post as soon as the error occurs acessing the repository via SSH from any ip-address with any user account produces the error message. Our jenkins server has its own ip-adress separate from the office and even starting a new ec2 server with a new ip-address does not allow one to clone the repository.

To further test this I just created an ec2 server in us-east-1 (our office and all our servers are normally based in germany) and that server produces the exact same error message after about 5 seconds of git clone.

EDIT: It just started working again for my teammates and me

Unfortunately, only the Gitlab team/employees can help you with this - obviously they have an infrastructure issue or something that is just way too sensitive if it is blocking after 5 seconds of activity.

Thanks for testing. There might be a specific problem with the Git repository data/content which causes this behavior.

I’d suggest opening a bug report, and link this forum topic too. Thanks!

Thanks for your input. I have created a bug report with all available information: "Maximum time in concurrency queue reached" when using git ssh for one specific repository on gitlab.com (#388285) · Issues · GitLab.org / GitLab · GitLab

1 Like