Unable to install GitLab EE in Ubuntu 16.04 TLS

I am facing some issue while installing the GitLab (Enterprise Edition) in my env, the OS details as below -

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.5 LTS
Release: 16.04
Codename: xenial
Linux H214AP002 4.4.0-116-generic #140-Ubuntu SMP Mon Feb 12 21:23:04 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

The GitLab instructions being used is - https://about.gitlab.com/installation/#ubuntu

Here is the steps I follow and the output -

  1. sudo apt-get update
    Ign:1 http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.2 InRelease
    Hit:2 http://us.archive.ubuntu.com/ubuntu xenial InRelease
    Hit:3 http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.2 Release
    Get:4 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease [109 kB]
    Get:6 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease [107 kB]
    Get:7 http://security.ubuntu.com/ubuntu xenial-security InRelease [107 kB]
    Get:8 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [812 kB]

Fetched 4,791 kB in 2s (2,132 kB/s)
Reading package lists… Done

  1. sudo apt-get install -y curl openssh-server ca-certificates
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    ca-certificates is already the newest version (20170717~16.04.1).
    curl is already the newest version (7.47.0-1ubuntu2.8).
    openssh-server is already the newest version (1:7.2p2-4ubuntu2.4).
    The following packages were automatically installed and are no longer required:
    libllvm5.0 linux-headers-4.4.0-87 linux-headers-4.4.0-87-generic linux-image-4.4.0-87-generic linux-image-extra-4.4.0-87-generic
    Use ‘sudo apt autoremove’ to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Note: I am not installing postfix using “sudo apt-get install -y postfix” as I am going to use my another setup for email.

  1. curl https://packages.gitlab.com/install/repositories/gitlab/gitlab-ee/script.deb.sh | sudo bash

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
curl: (60) server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
More details here: http://curl.haxx.se/docs/sslcerts.html

curl performs SSL certificate verification by default, using a “bundle”
of Certificate Authority (CA) public keys (CA certs). If the default
bundle file isn’t adequate, you can specify an alternate file
using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
the bundle, the certificate verification probably failed due to a
problem with the certificate (it might be expired, or the name might
not match the domain name in the URL).
If you’d like to turn off curl’s verification of the certificate, use
the -k (or --insecure) option.

I keep receiving above error every time, I tried with -k as well as --insecure options but no luck. I also tried to install manually but the system not letting me upload the package due to self-signed SSL cert of the GitLab package.

Can someone please help me out to get rid of this issue?

few more links of step#1 (sudo apt-get update) which I couldnt add due to forum restrictions -
Get:9 http://us.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [740 kB]
Get:10 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages [525 kB]
Get:11 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [645 kB]
Get:12 http://us.archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [586 kB]
Get:13 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 Packages [16.4 kB]
Get:14 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages [461 kB]
Get:15 http://us.archive.ubuntu.com/ubuntu xenial-updates/multiverse i386 Packages [15.5 kB]
Get:16 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages [361 kB]
Get:17 http://security.ubuntu.com/ubuntu xenial-security/universe i386 Packages [307 kB]