Unpacking backup failed

Hi,

I am trying to move a self-hosted Gitlab instance, from one server to another.
Both servers are up to date, running the same Gitlab version.

I did a full backup on the old server, using:
gitlab-backup create

I moved the archive to the new server, and I am trying to restore it, using:
gitlab-backup restore BACKUP=1624721546_2021_06_26_14.0.1-ee

Unfortunatelly, restoring the backup always fails. I get the following message, almost imeddiately after I run the restore command:
Unpacking backup ... unpacking backup failed.

The backup is stored in /var/opt/gitlab/backups.
The backup file is owned by the git user, and I made sure that both the file and the directory have the correct permissions (read and execute).

Any ideas what the problem may be?

Hi,

Have you tried to remove the last “-ee” part of you backup name?

Hi,

yes, I just tried and it fails again with the following message:
The backup file 1624979468_2021_06_29_14.0.1_gitlab_backup.tar does not exist!

So I guess I pass the correct name, as it actually finds the file, but cannot unpack it for some reason.

Any other ideas, please?