Upgrade 12.5.5->12.10.10 Issues

I was planning an upgrade from 12.5.5 to 13.0 and began with an upgrade to 12.10.10. During the process, I got an error regarding /var/opt/gitlab/gitlab-rails/shared/artifacts being unwritable. As an attempt to get around the issue, I renamed the symlink from artifacts to artifacts.orig. A subsequent upgrade to 12.10.10 was successful. However, once running on the new release, all jobs showed an error about unable to retrieve the job history (this is from memory). I assumed that was due to my rename of the artifacts symlink. So, I tried renaming the newly created artifacts to artifacts.new and renaming artifacts.orig->artifacts. This had no effect. I then tried reconfigure and restart, both of which also seemed to have no effect.

From there I tried falling back to the original release 12.5.5 and that also is not working. I did the following:
apt-get install gitlab-ee:amd64=12.5.5-ee.0
gitlab-ctl stop unicorn
gitlab-ctl stop puma
gitlab-ctl stop sidekiq
gitlab-backup restore BACKUP=15…
gitlab-ctl reconfigure
gitlab-ctl restart
gitlab-rake gitlab:check SANITIZE=true

All of the above seemed to work until the rake check. It gets an error “PG::ConnectionBad: Could not connect to the server: No such file or directory”
A gitlab-ctl status show postgresql, redis and registry all down.

Can anyone provide guidance on how to proceed?