Upgrade Gitlab from 12.10.14 to 13.0.14 unpackaging error


During an upgrade on a RedHat Machine from 12.10.14 to 13.0.14 I received the following error:

Error unpacking rpm package gitlab-ce-13.0.14-ce.0.el7.x86_64
error: unpacking of archive failed on file /opt/gitlab/embedded/service/mattermost/prepackaged_plugins/mattermost-plugin-aws-SNS-v1.0.2-linux-amd64.tar.gz;64de5069: cpio: read
Verifying : gitlab-ce-13.0.14-ce.0.el7.x86_64

The file exists and has same permissions as the others in same directory.

That error leaves the Gitlab unusable so I had to roll it back.

Any hints? Can I try the package for 13.1.11 instead?

Thanks a lot!

How are you running this upgrade? Can try couple of things
1 - move out this plugin in question mattermost-plugin-aws-SNS-v1.0.2-linux-amd64.tar.gz out of /opt/gitlab/embedded/service/mattermost/prepackaged_plugins/ directory
2 - if it tries to update and fails because of permissions, then you need permissions, so try running upgrade either as root or add sudo before your upgrade command

The first thing that struck me was that you’re dealing with two old versions of GitLab. 13.0.14 is probably over three years.

That error message suggests (but I left RedHat and derivaties over 20 years ago) one of two things to me:

  1. The downloaded rpm archive is corrupted. The first thing to try would be to redownload it.
  2. The disk the rpm is on is dying. You need more knowledge of your hardware than I have to give good advice on that situation.

GitLabs page on upgrading seems to have dropped all versions before 14 from the section on upgrade paths (but there’s still an info box talking about versions in the 13.8 series),

luckily the upgrade path tool still supports versions back to 12.10.14, and using that it seems like 13.0.14 is a required step on the path further, so you can’t use the package for 13.1.11 instead - there’s probably some migration that has to happen. But except for the security implications (I don’t remember if 13.0.14 was a security release) you could probably (no guarantee though) go a tiny step the other way and try 13.0.13 if you’re going to upgrade further (and you should), any migrations should be handled by all the 13.0 versions.


Thanks! I have to upgrade the installation with rpms downloaded separately as the server has no connection to the internet. So I use yum install as root.
I already tried it with the removed file. But it looks like this file is created from the package. As it was back after the next try.
And yes it is a pretty old version. I have to update it from 10.9.9, so some steps are already taken.
I will try an earlier version of 13.0 as proposed this evening and will report back.


I tried it with 13.03 newly downloaded and it worked. SO we are on the way. From 11.9.9 to 16.24
still 8 steps to go following the proposed upgrade path.
I have reached 14.0.12 w/o any further problems.