Upgrade path for 12.7.2-ee

Problem to solve

I have 2 old gitlab servers running 12.7.2-ee. I am unable to find a upgrade path to the latest version. any help is appreciated. Once i get them upgraded we are going to combine them into a new server.

Server Info:
lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 20.04.6 LTS
Release: 20.04
Codename: focal

uname -r
5.4.0-153-generic

Follow the upgrade path in Upgrade GitLab | GitLab and combine it with earlier versions from the docs archive. You can find earlier versions of the document in the Git history, or by selecting the upper right corner dropdown on docs.gitlab.com, i.e. by selecting 15.11.

First steps, follow 15.11 upgrade path and start with upgrading to the latest 12.x.y release.

Next steps, following current 16.10 upgrade path - start where you ended earlier in the 15.x upgrade path.

Alternatively, follow the suggested path in Upgrade Path

It is important to install specific versions during the upgrade path. There is no “catch all one time” upgrade procedure.

Suggestions

  1. Review breaking changes and deprecations before upgrades, so you can estimate potential missing features or configuration issues during the upgrade cycles.
  2. Upgrades also include database migrations, and might take a while. Plan with maintenance offline time.
  3. It is advised to create a backup before upgrading.
  4. AFAIK Ubuntu 20 LTS is still supported, so there is no immediate dist upgrade necessary (although might become relevant when 20 LTS goes EOL, and 24 LTS becomes available).
  5. Document shorter upgrade cycles to keep future installations secure and stable, and reduce upgrade maintenance.
1 Like

@iwalker FYI, I see this topic come up very frequently, which feels redundant in answers. I have compiled a list from this topic and others into a pinned forum topic. GitLab Upgrade Path Resources

2 Likes

I think some of the issue is the planner has a blank screen when selecting version 12 as current. I tried that for 12 to 13 on different browsers then decided to ask for help.

@dnsmichi looks like the upgrade path tool is broken. Just checked/verified.

Thanks. Suggest creating an issue in GitLab.com / GitLab Support Team / toolbox / upgrade-path · GitLab

Opened: Update path tool broken - blank screen instead of seeing update path (#49) · Issues · GitLab.com / GitLab Support Team / toolbox / upgrade-path · GitLab

1 Like

thanks guys, the tool now works but i now get an error of not found trying to do the upgrade. any suggestions.

apt-get install gitlab-ee=12.10.14-ee.0
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Version ‘12.10.14-ee.0’ for ‘gitlab-ee’ was not found

Yup, they solved it pretty quickly from the issue I opened: Update path tool broken - blank screen instead of seeing update path (#49) · Issues · GitLab.com / GitLab Support Team / toolbox / upgrade-path · GitLab :slight_smile:

I would suggest refreshing your repository configuration. Assuming you are using EE (enterprise version) and not CE (community), then:

curl https://packages.gitlab.com/install/repositories/gitlab/gitlab-ee/script.deb.sh | sudo bash

then re-check the commands to search for the package. You can check which package is installed first by doing:

dpkg -l | grep -i gitlab

it will either show gitlab-ee or gitlab-ce. If using CE, just change the URL in the above to gitlab-ce instead of gitlab-ee.

1 Like

Problems might also come come the fact that 12.7 (I didn’t check for the different patch levels) is from january 2020, which is appoximately 4 months earlier than Ubuntu Focal, so I don’t think official packages were ever made. And that’s probably also why you have trouble installing 12.10 that was released the day before Focal.
I would look into how that was achieved, and probably try to use official packages for Ubuntu Bionic (a simple edit of the sources should do, but wait) until I can use versions officially packages for Focal (apt-cache policy gitlab-ce on a machine using the focal repositories should tell you).

And just for good measure: The command @iwalker quotes from the documentation is bad, curl ... | sudo bash means you’re executing commands you don’t know (and a web server can easily be configured to return different things on these requests) with root privileges, i.e. you might trash your machine. The safe route is to download the script, read it, and execute the downloaded version.

1 Like

I did the commands then tried the update again and got the same not found error.
Version ‘12.10.14-ee.0’ for ‘gitlab-ee’ was not found

would i get past this f i upgraded Ubuntu. I am not the best at this, i know enough to be dangerous

As @grove said, there aren’t any Gitlab EE 12.x packages for Ubuntu 20.04. See: gitlab/gitlab-ee - Results for 'gitlab-ee_12' and focal in gitlab/gitlab-ee which I’ve filtered.

You’ll have to edit the /etc/apt/sources.list.d/gitlab-ee.list file (name might vary), and edit it to change from focal to bionic (which is Ubuntu 18) and try to upgrade to at least a 13.2 release before you can revert to focal.

1 Like

tried it, still got Version ‘12.10.14-ee.0’ for ‘gitlab-ee’ was not found

this is a virtual machine on vmware, and i cloned it to have a backup so i could update ubuntu to get off of focal if that is an option

Thanks for all the help, i have both servers up to date now. I forgot to do an ‘apt update’ , then i took my time and waited for all the migrations to finish before doing the next update, found out the hard way. now to combine 3 servers into one.

1 Like