Upgrade to v10.3.2-ce failed

On CentOS 6 I have recently upgraded from 8.13.7 (ce) to 10.3.2-ce using yum update. Something went wrong with the postgres database upgrade in that process (I’m sorry, I no longer have the logs, terminal won’t show that far back).

I was able to eventually get GitLab up and running again, but on a clean database. I have the old postgres data directory and am trying to rescue it. I have downloaded and installed the old postgres 9.2 binaries and am trying to manually run the pg_upgrade command using a newly initialized data directory and the old data directory as inputs:
/opt/gitlab/embedded/bin/pg_upgrade -b /usr/pgsql-9.2/bin -B /opt/gitlab/embedded/bin/ -d /var/opt/gitlab/postgresql/data.9.2.18 -D /var/opt/gitlab/postgresql/data.new/ --username=gitlab

When I run that command I get the error: connection to database failed: FATAL: Peer authentication failed for user “gitlab”

Can anyone help me out here? I’m on hour 4 and have exhausted my ideas.

Thank you!

Have you tried the steps outlined in the docs?

I sure did. Noting would save it. Luckily my installation was small (for a one man team, me), so I didn’t care about the todos, discussions, etc. I was able to just take the old git repos and create new repos from them on a new server. I didn’t get any of the nice gitlab stuff, but I didn’t have much to begin with. I’m just happy to have my repos and the history from them in a new server.