Users Unable to Use Both HTTPS and SSH Cloning On Same Computer

I’m running Gitlab CE 9.1.3 (I’m aware there’s one minor version upgrade available, I cannot upgrade due to another bug) on Ubuntu 16.04.

Users cannot clone projects using HTTPS when they have an SSH key for Gitlab on the system. I would expect they would be able to use both methods interchangeably on any machine.

When they try, they get an error message like:

Cloning into 'project-name'...
fatal: https://user@server/group/project-name.git/info/refs not valid: is this a git repository?

The projects can be cloned over HTTPS fine when there is no Gitlab SSH key on the system.

Is there some configuration option I’m missing? Is Gitlab trying to use the SSH key for HTTPS or something?

You should clone standard: git clone https://server/group/project-name.git

If you’re referring to the fact I have a user@ in my url, that url is directly provided by Gitlab on the project page that way ever since the upgrade to 9.0, and is not the issue.

did you try it?

Yes? This problem predates Gitlab adding the user@ in its urls, and it fails with the same error message either way, and regardless of which user is attempting it.

I ran the same test environment as you do but did not encounter any errors when git clone. Please double check the git clone of the user.

What is your Gitlab version and the OS version it is running on? Maybe it is a version difference.

I have replicated this issue across over a dozen projects, over several different users, and on 4 different test machines. It is most definitely an issue.

The users can always clone SSH fine, and clone HTTPS fine when not in the presence of a Gitlab SSH key. So it is not a matter of user clone permissions.

My test environment:
Gitlab 9.1.3 CE
Centos 6.9 Final
I do not know where your faults are but I wish you an error correction soon.