Vue.js build on CI/CD results in empty /dist directory

I’m attempting to add a build stage to my CI/CD pipeline that I’m running on The build seemingly ‘completes’ without error, but the /dist directory remains empty after the build.

Here’s the relevant config from my gitlab-ci.yml file:

enter image description here

But the result as seen in the runner logs is an empty /dist directory:

enter image description here

The runner reports that it found one matching files, but I’m assuming that it’s counting the empty /dist dir as the file that it found because the directory itself is empty, which causes my deploy stage to fail when it tries to upload the missing artifacts.

Does anyone have any idea what’s going on here?

The build seems to succeed just fine, but there’s no resulting files in the /dist directory. And with that in mind, where are they going then?

I’ve tried many different representations of the path, and even tried utilizing the process.env.CI_PROJECT_DIR var as the value in my webpack.config file(s) but I can’t get the artifacts to land in the /dist dir.

When I download the artifacts .zip file using the console I just end up with an empty folder.

Thanks in advance for any light anyone can shed on this.