13:create directory: mkdir /home/git/data/repositories/@hashed: permission denied

I have installed gitlab on my K8S1.15 experiment platform. After that, when I setup a new project, I got the following messages:
13:create directory: mkdir /home/git/data/repositories/@hashed: permission denied

The gitlab image I used is sameersbn/gitlab:12.1.6.
I used root account or git account to mkdir “/home/git/data/repositories/” then to setup a new project, the error was the same, somebody could tell me what’s wrong with it ? thanks a lot.

Replace this template with your information

Describe your question in as much detail as possible:

  • What are you seeing, and how does it differ from what you expect to see?
  • Consider including screenshots, error messages, and/or other helpful visuals
  • What version are you on (Hint: /help) ? and are you using self-managed or gitlab.com?
  • What troubleshooting steps have you already taken? Can you link to any docs or other resources so we know where you have been?

Thanks for taking the time to be thorough in your request, it really helps! :blush:

Check the permissions of this directory :

  • ls -la /home/git/data/repositories

In my gitlab-ce, all files/folders seem to be git:root, you can correct this with :

  • chown -R git:root /home/git/data/repositories/@hashed

Hi,

is there a specific reason not to use the official images but instead sameersbn/gitlab:12.1.6? This version is really outdated and does not receive any security updates anymore.

Its docs also mentions that it does install GitLab from source not being the recommended way.

In case you move over to using the official Docker images, please check here for instructions to fix the image permissions.

Cheers,
Michael

1 Like

I did what you told me to do like this:
image

It’s still the same error.

I’ll docker pull gitlab/gitlab-ce to have a try, thanks a lot.

After I changed the image to gitlab/gitlab-ce, the problem seems solved.

1 Like

2 Likes