413 - Remote end hung up unexpectedly


I am trying to make a fairly large commit (around 2GB) to my self hosted GitLab instance, this 2GB commit is already part of many commits I’m trying to do to get my 50GB repository online.

The Problem:

git push
Enumerating objects: 2208, done.
Counting objects: 100% (2208/2208), done.
Delta compression using up to 24 threads
Compressing objects: 100% (2142/2142), done.
Writing objects: 100% (2201/2201), 722.02 MiB | 29.59 MiB/s, done.
Total 2201 (delta 367), reused 0 (delta 0), pack-reused 0
error: RPC failed; HTTP 413 curl 22 The requested URL returned error: 413
send-pack: unexpected disconnect while reading sideband packet
fatal: the remote end hung up unexpectedly
Everything up-to-date

What I’ve tried:

Local Git Config:

git config --global http.postBuffer 157286400
git config --global http.maxRequestBuffer 157286400

gitlab.rb Config:

nginx['client_max_body_size'] = '102400m'


client_max_body_size 102400m;

also tried setting maximum push size and attachment size to 5000000 Mib via GitLab’s admin area.

My Setup:

I’m running GitLab v17.0.1-ee on Docker, along with Nginx 1.26.1 which has a proxy pass to gitlab’s nginx listening port. This all is running on an Ubuntu 24.04 VPS w/ 16gbs ram and plenty of storage.