500 error on Ubuntu 14.04 Server with Apache2.4

I am new to GitLab, and am trying to do an initial install.

Reading through the install documents, because of my configuration, it was recommended to install from source. I have a Ubuntu 14.04 server with Apache and existing GIT repos. Because of the existing Apache server pages, I will also want to rename the URL off from / (ie /gitlab).

I followed the install from source directions which I believe are from 8.14 successfully up to step 8 - Nginx. Since I already have Apache running, I followed the recipe to use gitlab-apache24.conf in the Apache2/site-available. I tailored this file per the instructions, with no success.

On a whim, I tried a connect to my localhost:8080 and SUCCESS!! I was presented with a Gitlab Login Screen which I was able to use the root access and login… Joy set in for the moment, but still no access from outside the server.

I found a similar topic on the forum (Setting up Gitlab on Ubuntu 14.04 with Apache2 without owning a domain name), but most of this summary applies to an Omnibus install which does not match the install from source files. I was able to leverage some of the discussion to get the Apache Proxy working, but now only 500 errors. These look like they are coming from Gitlab, but I cannot be sure.

Thanks in advance for advice on where to go from here…