After 13.7 upgrade, GitLab Pages always redirects to httpS (should be disabled)

Hi, I was wounding if anyone had any ideas, after an issue with GitLab pages after upgrading to 13.7.1 from 13.6.x

All my GitLab pages now want to redirect to HTTPS, even though I have in the gitlab.rb file, disabled the http_to_https config to false. I also noticed in the GitLab Pages preferences in a project, that there is a “New Domain” button and checkbox for “Force HTTPS”, which if I disabled I do not get the redirect.

The questions is why did that all of a sudden appear or get checked when I Upgraded and why is that option there when I do not have “custom domains” enabled (at least I think I dont). and/how would I disabled that checkbox for all projects.

Really hope someone has some insights.


What I have in /etc/gitlab/gitlab.rb

pages_external_url "http://......
gitlab_pages['enable'] = true
gitlab_pages['redirect_http'] = false
pages_nginx['enable'] = true
pages_nginx['redirect_http_to_https'] = false

sudo gitlab-rails console

 Ruby:         ruby 2.7.2p137 (2020-10-01 revision 5445e04352) [x86_64-linux]
 GitLab:       13.7.1-ee (d49cd5e5165) EE
 GitLab Shell: 13.14.0
 PostgreSQL:   11.9
Loading production environment (Rails
irb(main):001:0> Gitlab.config.pages.external_https
=> true
irb(main):002:0> Gitlab.config.pages.external_http
=> false


We have the same issue. We already have redirect http->https via reverse proxy. After this setting was enabled for all projects we began to observe a cyclic redirect https->https. Can you tell me how to disable this setting for all projects via the REST API?

Thank you.

Same problem here. Before the update to 13.7, pages_nginx[‘redirect_http_to_https’] hasn’t been set at all. I’ve set it to false and unchecked the button of a test project, but that didn’t help.

Then I’ve set gitlab_pages[‘access_control’] = false because I thought that it could be related. After that (and a rebuild of the pages of the project?), it worked (for that project). I’ve reenabled access_control and it still worked.
For a second project, I had to remove pages and build them again. Any ideas?

Good morning,

I ended up submitting to GitLab issue track as I had multiple instances with similar issues, so you can track here:

I had tried various things, and then suddenly the checkbox was unticked on projects (though still visible). I’m not sure, but think the https redirect stopped after I tried gitlab_pages['external_https'] = nil (or false) but let’s see what the developer say in the issue.