After enabling Apache (ubuntu 14.04) GitLab gives 502

I have successfully installed Ubuntu 14.04 on my VM and Ombinub GItLab along with it (I have chosen default settings).
After that I have noticed that during boot my apache doesn’t start.
I went on did some research and fixed apache problem with setting it to listen on port 8088 (I have configured that setting in the /etc/apache2/ports.conf).
After that I have noticed that GitLab is giving me 502 error.
Then I tried reverting the apache port settings and GitLab started working again.
I’m no Linux nor GitLab expert.
What confuses me is that I have specifically watched to give apache some port that is not occupied.
When I run sudo netstat -ltnp | grep “:8” I’m displayed with only two processes:

tcp 0 0* LISTEN 1368/
tcp 0 0* LISTEN 967/nginx

Can someone please point me in the right direction how to also enable apache to run alongside with GitLab?
Thank You.

You’d have to use a non bundled server, see and also read this similar topic Setting up Gitlab on Ubuntu 14.04 with Apache2 without owning a domain name