Always "Merge in progress" after press "Accept Merge Request"

After upgrading our Gitlab CE to version 7.12.2(30bffd5), we cannot “Accept Merge Request” and the green button is always in the spinning status… as shown below.

I used to working on Gitlab CE version 7.7(maybe) installed from source code and everything is perfect, but after upgrading to version 7.12, the feature does NOT work. I’ve tried to re-install (instead of upgrading) this version from source code but nothing different…

Could you please help me to solve the problem? I can provide any information if needed~
Thank you.

anybody? :worried:

I had the same issue on 7.13.2.
Please fix

We had the same problem. On our end it was because the merge in question was too big. sidekiq.log or application.log (can’t remember which) complained about the size.

Our solution: Edit $GITLAB_ROOT/ and modify line 11.

use Unicorn::WorkerKiller::Oom, (200 * (1 << 20)), (250 * (1 << 20))

My modification:
use Unicorn::WorkerKiller::Oom, (400 * (1 << 20)), (450 * (1 << 20))

Those values are basically MB memory limits for the workers. Adjust them carefully, since this applies to ALL workers, afaik.

I resolve the issue by investigate the githost.log.
For me, i run below command:
sudo -u git -H bundle install --path vendor/cache
sudo apt-get remove ruby1.9.1 libruby1.9.1

Take as reference.

having same issue since today morning…