API is not accessible

I have a new installation of the latest gitlab ce…

I’m able to create project and use the web interface…

But whats happening is that from the web interface i’m unable to add any files

Say add the Readme file, returns API is not accessible

I have an omnibus installation, over HTTP.

From the command line:

PS D:\dev> git clone http://USERNAME:TOKEN@gitlab.TLD:8080/USERNAME/PROJECTNAME.git
Cloning into ‘PROJECTNAME-server’…
fatal: unable to access ‘http://USERNAME:TOKEN@gitlab.TLD:8080/USERNAME/PROJECTNAME.git/’: The requested URL returned error: 500

Logs show:

{“severity”:“INFO”,“time”:“2020-04-01T18:10:48.863Z”,“correlation_id”:“bd004f6a-a652-4837-bbd6-f8a88ca72b68”,“message”:“Successful Login: username=USERNAME ip=MYIP method=standard admin=true”}

{“severity”:“INFO”,“time”:“2020-04-01T18:10:48.863Z”,“correlation_id”:“bd004f6a-a652-4837-bbd6-f8a88ca72b68”,“message”:“Successful Login: username=USERNAME ip=MYIP method=standard admin=true”}

  1. Parameters: {“service”=>“git-upload-pack”, “namespace_id”=>“USERNAME”, “repository_id”=>“PROJECTNAME.git”}
  2. Completed 500 Internal Server Error in 84ms (ActiveRecord: 22.9ms | Elasticsearch: 0.0ms | Allocations: 12829)
  3. JWT::DecodeError (Nil JSON web token):
  4. lib/gitlab/jwt_authenticatable.rb:17:in `decode_jwt_for_issuer’
  5. lib/gitlab/workhorse.rb:192:in `decode_jwt’
  6. lib/gitlab/workhorse.rb:188:in `verify_api_request!’
  7. app/controllers/concerns/workhorse_request.rb:13:in `verify_workhorse_api!’
  8. app/controllers/application_controller.rb:479:in `set_current_admin’
  9. lib/gitlab/i18n.rb:55:in `with_locale’
  10. lib/gitlab/i18n.rb:61:in `with_user_locale’
  11. app/controllers/application_controller.rb:464:in `set_locale’
  12. lib/gitlab/error_tracking.rb:34:in `with_context’
  13. app/controllers/application_controller.rb:555:in `sentry_context’
  14. lib/gitlab/application_context.rb:46:in `block in use’
  15. lib/gitlab/application_context.rb:46:in `use’
  16. lib/gitlab/application_context.rb:19:in `with_context’
  17. app/controllers/application_controller.rb:455:in `set_current_context’
  18. lib/gitlab/middleware/rails_queue_duration.rb:27:in `call’
  19. lib/gitlab/metrics/rack_middleware.rb:17:in `block in call’
  20. lib/gitlab/metrics/transaction.rb:62:in `run’
  21. lib/gitlab/metrics/rack_middleware.rb:17:in `call’
  22. lib/gitlab/request_profiler/middleware.rb:17:in `call’
  23. lib/gitlab/middleware/go.rb:20:in `call’
  24. lib/gitlab/etag_caching/middleware.rb:13:in `call’
  25. lib/gitlab/middleware/multipart.rb:121:in `call’
  26. lib/gitlab/middleware/read_only/controller.rb:53:in `call’
  27. lib/gitlab/middleware/read_only.rb:18:in `call’
  28. lib/gitlab/middleware/basic_health_check.rb:25:in `call’
  29. lib/gitlab/middleware/request_context.rb:23:in `call’
  30. config/initializers/fix_local_cache_middleware.rb:9:in `call’
  31. lib/gitlab/metrics/requests_rack_middleware.rb:49:in `call’
  32. lib/gitlab/middleware/release_env.rb:12:in `call’

Note that i have never been able to clone via command line, or adding of files via the web portal.

Anyone? I’m completely stuck here.

Anyone?

Also note that this is an omnibus self-hosted installation.